X (FKA Twitter) incident
Incident Report for Embedly
Resolved
This incident has been resolved.
Posted May 20, 2024 - 13:21 EDT
Identified
We've identified an issue impacting x, formerly known as twitter, embeds. A fix is being deployed shortly, and we'll continue to monitor.
Posted May 20, 2024 - 12:38 EDT
This incident affected: Embed.