app dashboard unavailable
Incident Report for Embedly
Resolved
This incident has been resolved.
Posted about 1 year ago. Sep 12, 2016 - 01:02 EDT
Investigating
We're reviewing an issue with our app dashboard access is temporarily unavailable.
Posted about 1 year ago. Sep 11, 2016 - 21:30 EDT